Multiple Client Versions

Discussion in 'Nukkit discussions and help' started by LameSheep, 28/8/16.

  1. This site uses cookies. By continuing to use this site, you are agreeing to our use of cookies. Learn More.
Dismiss Notice
We welcome you on our site. This site is devoted to the Nukkit project and all that is connected with him. Here you can communicate, download plugins, also many other things get acquainted! Register the account right now :3
  1. LameSheep

    LameSheep Пользователь

    Messages:
    4
    Likes Received:
    0
    Hello,


    I am trying to set up a home server for my kids ...

    I have downloaded the latest JAR and got it working with the latest client on iPhones ...

    However, i have some iPhone 4 devices that cant be upgraded past MCPE 0.14.3

    Is there any way that i can connect them to my Nukkit server?

    Cheers,

    LameSheep.
     
  2. fromgate

    fromgate Administrator

    Messages:
    681
    Likes Received:
    195
    Hello!

    You cannot use different client versions on the server.
    Sometime (on minor changes) you can use AnyVersion plugins (for example it could work with 0.13.0 and 0.13.1) but on bigger changes it will not help.

    So you can only try to use older version of Nukkit for your iPhone 4 devices.
     
  3. Tee7even

    Tee7even Nukkit Coders Team

    Messages:
    126
    Likes Received:
    27
    Yes, in fact there is a plugin by fromgate. But this is not a good idea. There's too much changes since that version. Either upgrade your "iPhone 4 devices" or downgrade the game on other devices.
     
  4. LameSheep

    LameSheep Пользователь

    Messages:
    4
    Likes Received:
    0
    Thanks guys ... I don't see why this is :(


    So I 'found' some ipad 2's ...

    and now have the problem that they are on the latest version 15.7 and nukkit is only 15.6 !

    any tips on downgrading the ipads to15.6 ? all the items I can find on the web do not seem to work for minecraft (xml files don't seem to have the version array in them) :(

    and iTunes/IOS9 doesn't allow copying from a device that does have 15.6 on it :(
     
  5. Tee7even

    Tee7even Nukkit Coders Team

    Messages:
    126
    Likes Received:
    27
    I think it should work with 0.15.7. It's just a skin pack update, isn't it?
     
  6. LameSheep

    LameSheep Пользователь

    Messages:
    4
    Likes Received:
    0
    awesome - yes, you are right .. I now have 2 kids that I wont see for the rest of the day :)


    now I need to work out how to get the multiworld plugin working and upload the worlds from their old phones ... I have the plugin working and have uploaded a world from their phone to test it and it seems to load ok, but not sure how to get to it from in the game yet -
     
  7. LameSheep

    LameSheep Пользователь

    Messages:
    4
    Likes Received:
    0
    I now have a raspberry pi (A) running as a wifi access point with DLNA and Minecraft as part of my car 'puter system .. yes they are spoiled kids - but we are about to go on a 5000km road trip ;)
     
  8. Tee7even

    Tee7even Nukkit Coders Team

    Messages:
    126
    Likes Received:
    27
    I don't know if that's your case, but for local games you should try to teach your kids how to connect their devices with each other without server in between. The game has such a feature. It will be way smoother and less painful, since Nukkit and any other server software are developed by third-party developers and none of them is complete yet.
     

Share This Page